IE 5.x and 6.x do not seem to transmit POST-Variables from form to form (php or CGI) when running over a https.

The problem might be that 56-bit export versions of MSIE 5.x browsers have broken SSLv3 implementation, which interacts badly with OpenSSL versions greater than 0.9.4. You can either accept this and force your clients to upgrade their browsers, downgrade to OpenSSL 0.9.4, or work around it by disabling only the problematic ciphers:

SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA: +HIGH: +MEDIUM: +LOW: +SSLv2: +EXP 

This also allows the broken MSIE versions work, but only removes the newer 56-bit TLS ciphers.